Flexi Pages Widget update. v1.6.1

Flexi Pages Widget updated to version 1.6.1.

  • Fixed the include/hierarchy issue
  • ‘current_page_ancestor’ and ‘current_page_parent’ classes shown.

At least one major issue has been fixed in this release. There may still be issues with this version. If so, your feedback welcome.

Versions 1.5.10 and older used the wp_list_pages() function to generate the pages list. But from v1.6, we have our own function to generate the list, we don’t use wp_list_pages() anymore. So the latest version of our plugin may not work well with certain other plugins that acts on or filters wp_list_pages(). In case you use FP Widget with such a plugin, you can always download and use an older version of Flexi Pages Widget plugin.

Flexi Pages Widget 1.6

Flexi Pages Widget plugin for WordPress updated to version 1.6.

  • New feature to show the items in the widget as dropdown.
  • Core functions have been thoroughly overhauled. Hopefully no more strange behaviour when some options are selected, and better compatibility with latest version of WP and certain themes and plugins.
  • Localization in Catalan and Dutch languages added. Thanks to Robert Buj Gelonch and Rene for the respective translations.

I have not been able to respond to all the comments and emails in the last two weeks or so. That’s because I was busy, and the little time I had for my plugins and themes, I chose to work on improving and updating them based on the feedback recieved instead of actually replying to the feedback. 🙂

That said, I will try and respond and reply to as many emails and comments as possible in the next few days. Thanks for your patience!